Kinect 4 Azure SDK by LightBuzz

Namespaces
Namespace | Description
LightBuzz.Kinect4Azure | The Azure Kinect Unity SDK by LightBuzz.
LightBuzz.Kinect4Azure.Avateering | Avatar animation in the 3D and 2D space.
LightBuzz.Kinect4Azure.Video | Video recording and playback module.


LightBuzz.Kinect4Azure Namespace

The Azure Kinect Unity SDK by LightBuzz.
Classes
 | Class | Description
Public class | Body | Represents a human Body.
Public class | BodyExtensions | Common Body utlities.
Public class | BodyFrameSource | Represents a Body frame source.
Public class | ColorFrameSource | Represents a Color frame source.
Public class | Configuration | Encapsulates the configuration parameters of a Kinect sensor device.
Public class | ConfigurationExtensions | Sensor configuration extensions.
Public class | CoordinateMapper | Provides transformations across the 2D and 3D space.
Public class | DepthFrameSource | Represents a Depth frame source.
Public class | Floor | Represents a Floor plane.
Public class | FloorFrameSource | Represents a Floor frame source.
Public class | Frame | Encapsulates Azure Kinect frame data.
Public class | IMU | Represents and Inertial Measurement Unit (e.g. Accelerometer/Gyroscope).
Public class | IMUFrameSource | Represents an Inertial Measurement Unit (IMU: Accelerometer and Gyroscope) frame source.
Public class | Joint | Represents a human body joint.
Public class | Jpeg | JPEG encoding and decoding.
Public class | KinectSensor | Represents an Azure Kinect sensor device.
Public class | UserFrameSource | Represents a User Index Map frame source.
Enumerations
 | Enumeration | Description
Public enumeration | ColorFormat | Color image format type.
Public enumeration | ColorResolution | Color sensor resolutions.
Public enumeration | DepthMode | Depth sensor capture modes.
Public enumeration | FieldOfView | The field of view of the camera.
Public enumeration | FramesPerSecond | Color and depth sensor frame rate.
Public enumeration | JointType | Represents the Azure Kinect joint types.
Public enumeration | TrackingState | The tracking state.


Body Class

Represents a human Body.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureBody

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Body

The Body type exposes the following members.

Properties
 | Name | Description
Public property | ID | The unique identifier of the current Body.
Public property | Joints | The human body joints.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LightBuzz.Kinect4Azure Namespace


Body Properties

The Body type exposes the following members.

Properties
 | Name | Description
Public property | ID | The unique identifier of the current Body.
Public property | Joints | The human body joints.
Top
See Also

Reference

Body Class


Body.ID Property

LightBuzz Kinect 4 Azure SDK

BodyID Property

The unique identifier of the current Body.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public uint ID { get; }

Property Value

Type: UInt32
See Also

Reference

Body Class


Body.Joints Property

BodyJoints Property

The human body joints.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Dictionary<JointType, Joint> Joints { get; }

Property Value

Type: DictionaryJointType, Joint
See Also

Reference

Body Class


Body Methods

The Body type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Body Class


BodyExtensions Class

Common Body utlities.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureBodyExtensions

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static class BodyExtensions

The BodyExtensions type exposes the following members.

Methods
Name | Description
Center | Returns the center body.
Closest | Returns the closest body.
Farthest | Returns the farthest body.
Left | Returns the leftmost body.
Right | Returns the rightmost body.
Top
See Also

Reference


BodyExtensions Methods

The BodyExtensions type exposes the following members.

Methods
Name | Description
Center | Returns the center body.
Closest | Returns the closest body.
Farthest | Returns the farthest body.
Left | Returns the leftmost body.
Right | Returns the rightmost body.
Top
See Also

Reference

BodyExtensions Class


BodyExtensions.Center Method

BodyExtensionsCenter Method

Returns the center body.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static Body Center(
    this IList<Body> bodies
)

Parameters

bodies
Type: System.Collections.GenericIListBody
A list of bodies.

Return Value

Type: Body
The center body.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IListBody . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BodyExtensions Class


BodyExtensions.Closest Method

BodyExtensionsClosest Method

Returns the closest body.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static Body Closest(
    this IList<Body> bodies
)

Parameters

bodies
Type: System.Collections.GenericIListBody
A list of bodies.

Return Value

Type: Body
The closest body.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IListBody . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BodyExtensions Class


BodyExtensions.Farthest Method

BodyExtensionsFarthest Method

Returns the farthest body.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static Body Farthest(
    this IList<Body> bodies
)

Parameters

bodies
Type: System.Collections.GenericIListBody
A list of bodies.

Return Value

Type: Body
The farthest body.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IListBody . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BodyExtensions Class


BodyExtensions.Left Method

BodyExtensionsLeft Method

Returns the leftmost body.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static Body Left(
    this IList<Body> bodies
)

Parameters

bodies
Type: System.Collections.GenericIListBody
A list of bodies.

Return Value

Type: Body
The leftmost body.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IListBody . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BodyExtensions Class


BodyExtensions.Right Method

BodyExtensionsRight Method

Returns the rightmost body.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static Body Right(
    this IList<Body> bodies
)

Parameters

bodies
Type: System.Collections.GenericIListBody
A list of bodies.

Return Value

Type: Body
The rightmost body.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IListBody . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BodyExtensions Class


BodyFrameSource Class

Represents a Body frame source.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureBodyFrameSource

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class BodyFrameSource

The BodyFrameSource type exposes the following members.

Constructors
 | Name | Description
Public method | BodyFrameSource | Initializes a new instance of the BodyFrameSource class
Top
Properties
 | Name | Description
Public property | Bodies | The human Body data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


BodyFrameSource Constructor

Initializes a new instance of the BodyFrameSource class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public BodyFrameSource()
See Also

Reference

BodyFrameSource Class


BodyFrameSource Properties

The BodyFrameSource type exposes the following members.

Properties
 | Name | Description
Public property | Bodies | The human Body data.
Top
See Also

Reference

BodyFrameSource Class


BodyFrameSource.Bodies Property

BodyFrameSourceBodies Property

The human Body data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Body> Bodies { get; }

Property Value

Type: ListBody
See Also

Reference

BodyFrameSource Class


BodyFrameSource Methods

The BodyFrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BodyFrameSource Class


ColorFormat Enumeration

Color image format type.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum ColorFormat
Members
Member name | Value | Description
MJPG | 0 | Color image type MJPG.
NV12 | 1 | Color image type NV12.
YUY2 | 2 | Color image type YUY2.
BGRA32 | 3 | Color image type BGRA32.
DEPTH16 | 4 | Depth image type DEPTH16.
IR16 | 5 | Image type IR16.
CUSTOM8 | 6 | Single channel image type CUSTOM8.
CUSTOM16 | 7 | Single channel image type CUSTOM16.
CUSTOM | 8 | Custom image format.
See Also

Reference


ColorFrameSource Class

Represents a Color frame source.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureColorFrameSource

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class ColorFrameSource

The ColorFrameSource type exposes the following members.

Constructors
 | Name | Description
Public method | ColorFrameSource | Initializes a new instance of the ColorFrameSource class
Top
Properties
 | Name | Description
Public property | BytesPerPixel | The number of bytes per pixel.
Public property | Data | The buffer (byte array) of the frame.
Public property | Height | The height of the frame (in pixels).
Public property | PointCloud | The BGRA color values of the point cloud. Attention: you should set enable the GeneratePointCloud configuration option to true.
Public property | Stride | The stride of the frame.
Public property | Width | The width of the frame (in pixels).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


ColorFrameSource Constructor

Initializes a new instance of the ColorFrameSource class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ColorFrameSource()
See Also

Reference

ColorFrameSource Class


ColorFrameSource Properties

The ColorFrameSource type exposes the following members.

Properties
 | Name | Description
Public property | BytesPerPixel | The number of bytes per pixel.
Public property | Data | The buffer (byte array) of the frame.
Public property | Height | The height of the frame (in pixels).
Public property | PointCloud | The BGRA color values of the point cloud. Attention: you should set enable the GeneratePointCloud configuration option to true.
Public property | Stride | The stride of the frame.
Public property | Width | The width of the frame (in pixels).
Top
See Also

Reference

ColorFrameSource Class


ColorFrameSource.BytesPerPixel Property

ColorFrameSourceBytesPerPixel Property

The number of bytes per pixel.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int BytesPerPixel { get; }

Property Value

Type: Int32
See Also

Reference

ColorFrameSource Class


ColorFrameSource.Data Property

ColorFrameSourceData Property

The buffer (byte array) of the frame.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public byte[] Data { get; }

Property Value

Type: Byte
See Also

Reference

ColorFrameSource Class


ColorFrameSource.Height Property

ColorFrameSourceHeight Property

The height of the frame (in pixels).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Height { get; }

Property Value

Type: Int32
See Also

Reference

ColorFrameSource Class


ColorFrameSource.PointCloud Property

ColorFrameSourcePointCloud Property

The BGRA color values of the point cloud. Attention: you should set enable the GeneratePointCloud configuration option to true.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public BGRA[] PointCloud { get; }

Property Value

Type: BGRA
See Also

Reference

ColorFrameSource Class


ColorFrameSource.Stride Property

ColorFrameSourceStride Property

The stride of the frame.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Stride { get; }

Property Value

Type: Int32
See Also

Reference

ColorFrameSource Class


ColorFrameSource.Width Property

ColorFrameSourceWidth Property

The width of the frame (in pixels).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Width { get; }

Property Value

Type: Int32
See Also

Reference

ColorFrameSource Class


ColorFrameSource Methods

The ColorFrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorFrameSource Class


ColorResolution Enumeration

Color sensor resolutions.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum ColorResolution
Members
Member name | Value | Description
ColorResolution_OFF | 0 | Color camera will be turned off with this setting.
ColorResolution_720P | 1 | 1280x720 (16:9)
ColorResolution_1080P | 2 | 1920x1080 (16:9)
ColorResolution_1440P | 3 | 2560x1440 (16:9)
ColorResolution_1536P | 4 | 2048x1536 (4:3)
ColorResolution_2160P | 5 | 3840x2160 (16:9)
ColorResolution_3072P | 6 | 4096x3072 (4:3)
See Also

Reference


Configuration Class

Encapsulates the configuration parameters of a Kinect sensor device.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureConfiguration

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class Configuration

The Configuration type exposes the following members.

Constructors
 | Name | Description
Public method | Configuration | Initializes a new instance of the Configuration class
Top
Properties
 | Name | Description
Public property | ColorFormat | The color image format.
Public property | ColorResolution | The color image resolution.
Public property | DepthMode | The depth mode.
Public property | DeviceIndex | The index of the current device.
Public property | EnableColorPointCloud | Specifies whether the sensor should generate a color point cloud.
Public property | EnableDepthPointCloud | Specifies whether the sensor should generate a depth point cloud.
Public property | EnableFloorTracking | Specifies whether the sensor should generate a depth point cloud.
Public property | EnableIMU | Specifies whether the sensor should enable the IMU. ATTENTION: As reported to Microsoft, the IMU is causing a memory leak. Use with caution! https://github.com/microsoft/Azure-Kinect-Sensor-SDK/issues/1230
Public property | FPS | The frame rate.
Public property | ProcessingMode | Specifies the body-tracking processing mode (CPU/GPU). GPU provides significantly better tracking.
Public property | SensorOrientation | Specifies the sensor orientation for body-tracking. This will not rotate the color/depth view; it will simply optimize body-tracking for the desired sensor rotation.
Public property | Smoothing | Specifies the temporal smoothing across frames (0.0 - 1.0). Set to 0.0 for no smoothing. Set to 1.0 for full smoothing. Less smoothing will increase the responsiveness of the detected skeletons but will cause more positional and orientational jitters.
Public property | SyncedImagesOnly | Specifies whether the device will only serve synchronized Color and Depth images.
Public property | WiredSyncMode | Specifies the wired sync mode of the device.
Top
Methods
 | Name | Description
Public method | Equals | Specifies whether two configurations are the same. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the hash function for the Configuration type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Lists the configuration parameters of the current Configuration. (Overrides ObjectToString.)
Top
Fields
Name | Description
DefaultColorFormat | The default color image format.
DefaultColorResolution | The default color image resolution.
DefaultDepthMode | The default depth mode format.
DefaultDeviceIndex | The default device index number.
DefaultEnableColorPointCloud | The default enable color-based point cloud option.
DefaultEnableDepthPointCloud | The default enable depth-based point cloud option.
DefaultEnableFloorTracking | The default enable floor tracking option.
DefaultEnableIMU | The default value for enabling the IMU unit.
DefaultFramePerSecond | The default frame rate.
DefaultProcessingMode | The default body-tracking processing mode (CPU/GPU).
DefaultSensorOrientation | The default sensor orientation.
DefaultSmoothing | The default body-tracking smoothing.
DefaultSyncedImagesOnly | The default synchronization mode of Color and Depth images.
DefaultWiredSyncMode | The default wired sync mode.
Top
See Also

Reference


Configuration Constructor

Initializes a new instance of the Configuration class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Configuration()
See Also

Reference

Configuration Class


Configuration Properties

The Configuration type exposes the following members.

Properties
 | Name | Description
Public property | ColorFormat | The color image format.
Public property | ColorResolution | The color image resolution.
Public property | DepthMode | The depth mode.
Public property | DeviceIndex | The index of the current device.
Public property | EnableColorPointCloud | Specifies whether the sensor should generate a color point cloud.
Public property | EnableDepthPointCloud | Specifies whether the sensor should generate a depth point cloud.
Public property | EnableFloorTracking | Specifies whether the sensor should generate a depth point cloud.
Public property | EnableIMU | Specifies whether the sensor should enable the IMU. ATTENTION: As reported to Microsoft, the IMU is causing a memory leak. Use with caution! https://github.com/microsoft/Azure-Kinect-Sensor-SDK/issues/1230
Public property | FPS | The frame rate.
Public property | ProcessingMode | Specifies the body-tracking processing mode (CPU/GPU). GPU provides significantly better tracking.
Public property | SensorOrientation | Specifies the sensor orientation for body-tracking. This will not rotate the color/depth view; it will simply optimize body-tracking for the desired sensor rotation.
Public property | Smoothing | Specifies the temporal smoothing across frames (0.0 - 1.0). Set to 0.0 for no smoothing. Set to 1.0 for full smoothing. Less smoothing will increase the responsiveness of the detected skeletons but will cause more positional and orientational jitters.
Public property | SyncedImagesOnly | Specifies whether the device will only serve synchronized Color and Depth images.
Public property | WiredSyncMode | Specifies the wired sync mode of the device.
Top
See Also

Reference

Configuration Class


Configuration.ColorFormat Property

ConfigurationColorFormat Property

The color image format.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ColorFormat ColorFormat { get; set; }

Property Value

Type: ColorFormat
See Also

Reference

Configuration Class


Configuration.ColorResolution Property

ConfigurationColorResolution Property

The color image resolution.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ColorResolution ColorResolution { get; set; }

Property Value

Type: ColorResolution
See Also

Reference

Configuration Class


Configuration.DepthMode Property

ConfigurationDepthMode Property

The depth mode.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DepthMode DepthMode { get; set; }

Property Value

Type: DepthMode
See Also

Reference

Configuration Class


Configuration.DeviceIndex Property

ConfigurationDeviceIndex Property

The index of the current device.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int DeviceIndex { get; set; }

Property Value

Type: Int32
See Also

Reference

Configuration Class


Configuration.EnableColorPointCloud Property

ConfigurationEnableColorPointCloud Property

Specifies whether the sensor should generate a color point cloud.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool EnableColorPointCloud { get; set; }

Property Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.EnableDepthPointCloud Property

ConfigurationEnableDepthPointCloud Property

Specifies whether the sensor should generate a depth point cloud.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool EnableDepthPointCloud { get; set; }

Property Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.EnableFloorTracking Property

ConfigurationEnableFloorTracking Property

Specifies whether the sensor should generate a depth point cloud.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool EnableFloorTracking { get; set; }

Property Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.EnableIMU Property

ConfigurationEnableIMU Property

Specifies whether the sensor should enable the IMU. ATTENTION: As reported to Microsoft, the IMU is causing a memory leak. Use with caution! https://github.com/microsoft/Azure-Kinect-Sensor-SDK/issues/1230

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool EnableIMU { get; set; }

Property Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.FPS Property

ConfigurationFPS Property

The frame rate.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public FramesPerSecond FPS { get; set; }

Property Value

Type: FramesPerSecond
See Also

Reference

Configuration Class


Configuration.ProcessingMode Property

ConfigurationProcessingMode Property

Specifies the body-tracking processing mode (CPU/GPU). GPU provides significantly better tracking.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TrackerProcessingMode ProcessingMode { get; set; }

Property Value

Type: TrackerProcessingMode
See Also

Reference

Configuration Class


Configuration.SensorOrientation Property

ConfigurationSensorOrientation Property

Specifies the sensor orientation for body-tracking. This will not rotate the color/depth view; it will simply optimize body-tracking for the desired sensor rotation.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public SensorOrientation SensorOrientation { get; set; }

Property Value

Type: SensorOrientation
See Also

Reference

Configuration Class


Configuration.Smoothing Property

ConfigurationSmoothing Property

Specifies the temporal smoothing across frames (0.0 - 1.0). Set to 0.0 for no smoothing. Set to 1.0 for full smoothing. Less smoothing will increase the responsiveness of the detected skeletons but will cause more positional and orientational jitters.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Smoothing { get; set; }

Property Value

Type: Single
See Also

Reference

Configuration Class


Configuration.SyncedImagesOnly Property

ConfigurationSyncedImagesOnly Property

Specifies whether the device will only serve synchronized Color and Depth images.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool SyncedImagesOnly { get; set; }

Property Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.WiredSyncMode Property

ConfigurationWiredSyncMode Property

Specifies the wired sync mode of the device.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public WiredSyncMode WiredSyncMode { get; set; }

Property Value

Type: WiredSyncMode
See Also

Reference

Configuration Class


Configuration Methods

The Configuration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Specifies whether two configurations are the same. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the hash function for the Configuration type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Lists the configuration parameters of the current Configuration. (Overrides ObjectToString.)
Top
See Also

Reference

Configuration Class


Configuration.Equals Method

ConfigurationEquals Method

Specifies whether two configurations are the same.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The configuration to compare with.

Return Value

Type: Boolean
True if both configurations are the same. False otherwise.
See Also

Reference

Configuration Class


Configuration.GetHashCode Method

ConfigurationGetHashCode Method

Serves as the hash function for the Configuration type.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash representation of the current object.
See Also

Reference

Configuration Class


Configuration.ToString Method

ConfigurationToString Method

Lists the configuration parameters of the current Configuration.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A string representation of the current configuration.
See Also

Reference

Configuration Class


Configuration Fields

The Configuration type exposes the following members.

Fields
Name | Description
DefaultColorFormat | The default color image format.
DefaultColorResolution | The default color image resolution.
DefaultDepthMode | The default depth mode format.
DefaultDeviceIndex | The default device index number.
DefaultEnableColorPointCloud | The default enable color-based point cloud option.
DefaultEnableDepthPointCloud | The default enable depth-based point cloud option.
DefaultEnableFloorTracking | The default enable floor tracking option.
DefaultEnableIMU | The default value for enabling the IMU unit.
DefaultFramePerSecond | The default frame rate.
DefaultProcessingMode | The default body-tracking processing mode (CPU/GPU).
DefaultSensorOrientation | The default sensor orientation.
DefaultSmoothing | The default body-tracking smoothing.
DefaultSyncedImagesOnly | The default synchronization mode of Color and Depth images.
DefaultWiredSyncMode | The default wired sync mode.
Top
See Also

Reference

Configuration Class


Configuration.DefaultColorFormat Field

ConfigurationDefaultColorFormat Field

The default color image format.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const ColorFormat DefaultColorFormat = ColorFormat.MJPG

Field Value

Type: ColorFormat
See Also

Reference

Configuration Class


Configuration.DefaultColorResolution Field

ConfigurationDefaultColorResolution Field

The default color image resolution.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const ColorResolution DefaultColorResolution = ColorResolution.ColorResolution_1080P

Field Value

Type: ColorResolution
See Also

Reference

Configuration Class


Configuration.DefaultDepthMode Field

ConfigurationDefaultDepthMode Field

The default depth mode format.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const DepthMode DefaultDepthMode = DepthMode.NFOV_Unbinned

Field Value

Type: DepthMode
See Also

Reference

Configuration Class


Configuration.DefaultDeviceIndex Field

ConfigurationDefaultDeviceIndex Field

The default device index number.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const int DefaultDeviceIndex = 0

Field Value

Type: Int32
See Also

Reference

Configuration Class


Configuration.DefaultEnableColorPointCloud Field

ConfigurationDefaultEnableColorPointCloud Field

The default enable color-based point cloud option.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const bool DefaultEnableColorPointCloud = false

Field Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.DefaultEnableDepthPointCloud Field

ConfigurationDefaultEnableDepthPointCloud Field

The default enable depth-based point cloud option.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const bool DefaultEnableDepthPointCloud = false

Field Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.DefaultEnableFloorTracking Field

ConfigurationDefaultEnableFloorTracking Field

The default enable floor tracking option.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const bool DefaultEnableFloorTracking = false

Field Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.DefaultEnableIMU Field

ConfigurationDefaultEnableIMU Field

The default value for enabling the IMU unit.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const bool DefaultEnableIMU = false

Field Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.DefaultFramePerSecond Field

ConfigurationDefaultFramePerSecond Field

The default frame rate.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const FramesPerSecond DefaultFramePerSecond = FramesPerSecond.FPS_30

Field Value

Type: FramesPerSecond
See Also

Reference

Configuration Class


Configuration.DefaultProcessingMode Field

ConfigurationDefaultProcessingMode Field

The default body-tracking processing mode (CPU/GPU).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const TrackerProcessingMode DefaultProcessingMode = TrackerProcessingMode.Gpu

Field Value

Type: TrackerProcessingMode
See Also

Reference

Configuration Class


Configuration.DefaultSensorOrientation Field

ConfigurationDefaultSensorOrientation Field

The default sensor orientation.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const SensorOrientation DefaultSensorOrientation = SensorOrientation.Default

Field Value

Type: SensorOrientation
See Also

Reference

Configuration Class


Configuration.DefaultSmoothing Field

ConfigurationDefaultSmoothing Field

The default body-tracking smoothing.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const float DefaultSmoothing = 0.5f

Field Value

Type: Single
See Also

Reference

Configuration Class


Configuration.DefaultSyncedImagesOnly Field

ConfigurationDefaultSyncedImagesOnly Field

The default synchronization mode of Color and Depth images.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const bool DefaultSyncedImagesOnly = true

Field Value

Type: Boolean
See Also

Reference

Configuration Class


Configuration.DefaultWiredSyncMode Field

ConfigurationDefaultWiredSyncMode Field

The default wired sync mode.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const WiredSyncMode DefaultWiredSyncMode = WiredSyncMode.Standalone

Field Value

Type: WiredSyncMode
See Also

Reference

Configuration Class


ConfigurationExtensions Class

Sensor configuration extensions.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureConfigurationExtensions

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static class ConfigurationExtensions
Methods
Name | Description
Size(ColorResolution) | Returns the width and height of the current color resolution (in pixels).
Size(DepthMode) | Returns the width and height of the current depth mode (in pixels).
Top
See Also

Reference


ConfigurationExtensions Methods

Methods
Name | Description
Size(ColorResolution) | Returns the width and height of the current color resolution (in pixels).
Size(DepthMode) | Returns the width and height of the current depth mode (in pixels).
Top
See Also

Reference

ConfigurationExtensions Class


ConfigurationExtensions.Size Method

ConfigurationExtensionsSize Method

Overload List
Name | Description
Size(ColorResolution) | Returns the width and height of the current color resolution (in pixels).
Size(DepthMode) | Returns the width and height of the current depth mode (in pixels).
Top
See Also

Reference

ConfigurationExtensions Class


ConfigurationExtensions.Size Method (ColorResolution)

ConfigurationExtensionsSize Method (ColorResolution)

Returns the width and height of the current color resolution (in pixels).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static Size Size(
    this ColorResolution resolution
)

Parameters

resolution
Type: LightBuzz.Kinect4AzureColorResolution
The current color resolution.

Return Value

Type: Size
The width and height of the frame.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ColorResolution. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ConfigurationExtensions Class
Size Overload


ConfigurationExtensions.Size Method (DepthMode)

ConfigurationExtensionsSize Method (DepthMode)

Returns the width and height of the current depth mode (in pixels).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static Size Size(
    this DepthMode mode
)

Parameters

mode
Type: LightBuzz.Kinect4AzureDepthMode
The current depth mode.

Return Value

Type: Size
The width and height of the frame.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DepthMode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ConfigurationExtensions Class
Size Overload


CoordinateMapper Class

Provides transformations across the 2D and 3D space.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureCoordinateMapper

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class CoordinateMapper

The CoordinateMapper type exposes the following members.

Properties
 | Name | Description
Public property | Calibration | The native device calibration. Source: https://microsoft.github.io/Azure-Kinect-Sensor-SDK/master/struct_microsoft_1_1_azure_1_1_kinect_1_1_sensor_1_1_calibration.html
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MapColorToWorld | Maps the specified point from the 2D color space to the 3D world space.
Public method | MapDepthToWorld | Maps the specified point from the 2D depth space to the 3D world space.
Public method | MapWorldToColor | Maps the specified point from the 3D world space to the 2D color space.
Public method | MapWorldToDepth | Maps the specified point from the 3D world space to the 2D depth space.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


CoordinateMapper Properties

The CoordinateMapper type exposes the following members.

Properties
 | Name | Description
Public property | Calibration | The native device calibration. Source: https://microsoft.github.io/Azure-Kinect-Sensor-SDK/master/struct_microsoft_1_1_azure_1_1_kinect_1_1_sensor_1_1_calibration.html
Top
See Also

Reference

CoordinateMapper Class


CoordinateMapper.Calibration Property

CoordinateMapperCalibration Property

The native device calibration. Source: https://microsoft.github.io/Azure-Kinect-Sensor-SDK/master/struct_microsoft_1_1_azure_1_1_kinect_1_1_sensor_1_1_calibration.html

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Calibration Calibration { get; set; }

Property Value

Type: Calibration
See Also

Reference

CoordinateMapper Class


CoordinateMapper Methods

The CoordinateMapper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MapColorToWorld | Maps the specified point from the 2D color space to the 3D world space.
Public method | MapDepthToWorld | Maps the specified point from the 2D depth space to the 3D world space.
Public method | MapWorldToColor | Maps the specified point from the 3D world space to the 2D color space.
Public method | MapWorldToDepth | Maps the specified point from the 3D world space to the 2D depth space.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoordinateMapper Class


CoordinateMapper.MapColorToWorld Method

CoordinateMapperMapColorToWorld Method

Maps the specified point from the 2D color space to the 3D world space.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector3D MapColorToWorld(
    Vector2D point2D
)

Parameters

point2D
Type: Vector2D
The 2D color point.

Return Value

Type: Vector3D
The corresponding 3D world point.
See Also

Reference

CoordinateMapper Class


CoordinateMapper.MapDepthToWorld Method

CoordinateMapperMapDepthToWorld Method

Maps the specified point from the 2D depth space to the 3D world space.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector3D MapDepthToWorld(
    Vector2D point2D,
    float depth
)

Parameters

point2D
Type: Vector2D
The 2D depth point.
depth
Type: SystemSingle
The depth of the 2D point (in meters).

Return Value

Type: Vector3D
The corresponding 3D world point.
See Also

Reference

CoordinateMapper Class


CoordinateMapper.MapWorldToColor Method

CoordinateMapperMapWorldToColor Method

Maps the specified point from the 3D world space to the 2D color space.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector2D MapWorldToColor(
    Vector3D point3D
)

Parameters

point3D
Type: Vector3D
The 3D world point.

Return Value

Type: Vector2D
The corresponding 2D color point.
See Also

Reference

CoordinateMapper Class


CoordinateMapper.MapWorldToDepth Method

CoordinateMapperMapWorldToDepth Method

Maps the specified point from the 3D world space to the 2D depth space.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector2D MapWorldToDepth(
    Vector3D point3D
)

Parameters

point3D
Type: Vector3D
The 3D world point.

Return Value

Type: Vector2D
The corresponding 2D depth point.
See Also

Reference

CoordinateMapper Class


DepthFrameSource Class

Represents a Depth frame source.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureDepthFrameSource

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class DepthFrameSource

The DepthFrameSource type exposes the following members.

Constructors
 | Name | Description
Public method | DepthFrameSource | Initializes a new instance of the DepthFrameSource class
Top
Properties
 | Name | Description
Public property | BytesPerPixel | The number of bytes per pixel.
Public property | Data | The buffer (ushort array) of the frame. Measured in millimeters.
Public property | Height | The height of the frame (in pixels).
Public property | PointCloud | The 3D coordinates of the point cloud (measured in millimeters). Attention: you should set enable the GeneratePointCloud configuration option to true.
Public property | Stride | The stride of the frame.
Public property | Width | The width of the frame (in pixels).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


DepthFrameSource Constructor

Initializes a new instance of the DepthFrameSource class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DepthFrameSource()
See Also

Reference

DepthFrameSource Class


DepthFrameSource Properties

The DepthFrameSource type exposes the following members.

Properties
 | Name | Description
Public property | BytesPerPixel | The number of bytes per pixel.
Public property | Data | The buffer (ushort array) of the frame. Measured in millimeters.
Public property | Height | The height of the frame (in pixels).
Public property | PointCloud | The 3D coordinates of the point cloud (measured in millimeters). Attention: you should set enable the GeneratePointCloud configuration option to true.
Public property | Stride | The stride of the frame.
Public property | Width | The width of the frame (in pixels).
Top
See Also

Reference

DepthFrameSource Class


DepthFrameSource.BytesPerPixel Property

DepthFrameSourceBytesPerPixel Property

The number of bytes per pixel.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int BytesPerPixel { get; }

Property Value

Type: Int32
See Also

Reference

DepthFrameSource Class


DepthFrameSource.Data Property

DepthFrameSourceData Property

The buffer (ushort array) of the frame. Measured in millimeters.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ushort[] Data { get; }

Property Value

Type: UInt16
See Also

Reference

DepthFrameSource Class


DepthFrameSource.Height Property

DepthFrameSourceHeight Property

The height of the frame (in pixels).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Height { get; }

Property Value

Type: Int32
See Also

Reference

DepthFrameSource Class


DepthFrameSource.PointCloud Property

DepthFrameSourcePointCloud Property

The 3D coordinates of the point cloud (measured in millimeters). Attention: you should set enable the GeneratePointCloud configuration option to true.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Short3[] PointCloud { get; }

Property Value

Type: Short3
See Also

Reference

DepthFrameSource Class


DepthFrameSource.Stride Property

DepthFrameSourceStride Property

The stride of the frame.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Stride { get; }

Property Value

Type: Int32
See Also

Reference

DepthFrameSource Class


DepthFrameSource.Width Property

DepthFrameSourceWidth Property

The width of the frame (in pixels).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Width { get; }

Property Value

Type: Int32
See Also

Reference

DepthFrameSource Class


DepthFrameSource Methods

The DepthFrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DepthFrameSource Class


DepthMode Enumeration

Depth sensor capture modes.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum DepthMode
Members
Member name | Value | Description
Off | 0 | Depth sensor will be turned off with this setting.
NFOV_2X2Binned | 1 | Depth captured at 320x288. Passive IR is also captured at 320x288.
NFOV_Unbinned | 2 | Depth captured at 640x576. Passive IR is also captured at 640x576.
WFOV_2X2Binned | 3 | Depth captured at 512x512. Passive IR is also captured at 512x512.
WFOV_Unbinned | 4 | Depth captured at 1024x1024. Passive IR is also captured at 1024x1024.
PassiveIR | 5 | Passive IR only, captured at 1024x1024.
See Also

Reference


FieldOfView Enumeration

The field of view of the camera.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum FieldOfView
Members
Member name | Value | Description
OK | 0 | The field of view is OK.
Limited | 1 | The field of view is limited
See Also

Reference


Floor Class

Represents a Floor plane.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureFloor

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Floor

The Floor type exposes the following members.

Constructors
 | Name | Description
Public method | Floor(Floor) | Clones a floor plane.
Public method | Floor(Single, Single, Single, Single) | Creates a new Floor plane.
Top
Properties
 | Name | Description
Public property | FieldOfView | Returns whether the field of view is OK or limited.
Public property | Height | The vertical distance between the floor and the sensor (absolute value).
Public property | Tilt | Returns the tilt of the camera. Positive: the camera faces upwards. Negative: the camera faces downwards. Zero: the camera is straight. NaN: the accelerometer did not provide valid data or the field of view is very limited.
Top
Methods
 | Name | Description
Public method | Distance | Calculates the distance between the floor plane and the specified point in the 3D space.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | W | The vertical distance between the floor and the sensor.
Public field | X | The X coordinate of the normal vector.
Public field | Y | The Y coordinate of the normal vector.
Public field | Z | The Z coordinate of the normal vector.
Top
See Also

Reference


Floor Constructor

Overload List
 | Name | Description
Public method | Floor(Floor) | Clones a floor plane.
Public method | Floor(Single, Single, Single, Single) | Creates a new Floor plane.
Top
See Also

Reference

Floor Class


Floor Constructor (Floor)

Clones a floor plane.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Floor(
    Floor other
)

Parameters

other
Type: LightBuzz.Kinect4AzureFloor
The floor plane to clone.
See Also

Reference

Floor Class
Floor Overload


Floor Constructor (Single, Single, Single, Single)

Creates a new Floor plane.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Floor(
    float x,
    float y,
    float z,
    float w
)

Parameters

x
Type: SystemSingle
The X coordinate of the normal vector.
y
Type: SystemSingle
The Y coordinate of the normal vector.
z
Type: SystemSingle
The Z coordinate of the normal vector.
w
Type: SystemSingle
The vertical distance between the current and the sensor.
See Also

Reference

Floor Class
Floor Overload


Floor Properties

The Floor type exposes the following members.

Properties
 | Name | Description
Public property | FieldOfView | Returns whether the field of view is OK or limited.
Public property | Height | The vertical distance between the floor and the sensor (absolute value).
Public property | Tilt | Returns the tilt of the camera. Positive: the camera faces upwards. Negative: the camera faces downwards. Zero: the camera is straight. NaN: the accelerometer did not provide valid data or the field of view is very limited.
Top
See Also

Reference

Floor Class


Floor.FieldOfView Property

FloorFieldOfView Property

Returns whether the field of view is OK or limited.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public FieldOfView FieldOfView { get; }

Property Value

Type: FieldOfView
See Also

Reference

Floor Class


Floor.Height Property

FloorHeight Property

The vertical distance between the floor and the sensor (absolute value).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Height { get; }

Property Value

Type: Single
See Also

Reference

Floor Class


Floor.Tilt Property

FloorTilt Property

Returns the tilt of the camera. Positive: the camera faces upwards. Negative: the camera faces downwards. Zero: the camera is straight. NaN: the accelerometer did not provide valid data or the field of view is very limited.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Tilt { get; }

Property Value

Type: Single
See Also

Reference

Floor Class


Floor Methods

The Floor type exposes the following members.

Methods
 | Name | Description
Public method | Distance | Calculates the distance between the floor plane and the specified point in the 3D space.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Floor Class


Floor.Distance Method

FloorDistance Method

Calculates the distance between the floor plane and the specified point in the 3D space.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Distance(
    Vector3D point
)

Parameters

point
Type: Vector3D
A point in the 3D world space.

Return Value

Type: Single
The distance between the floor plane and the point (in meters).
See Also

Reference

Floor Class


Floor Fields

The Floor type exposes the following members.

Fields
 | Name | Description
Public field | W | The vertical distance between the floor and the sensor.
Public field | X | The X coordinate of the normal vector.
Public field | Y | The Y coordinate of the normal vector.
Public field | Z | The Z coordinate of the normal vector.
Top
See Also

Reference

Floor Class


Floor.W Field

FloorW Field

The vertical distance between the floor and the sensor.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float W

Field Value

Type: Single
See Also

Reference

Floor Class


Floor.X Field

FloorX Field

The X coordinate of the normal vector.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float X

Field Value

Type: Single
See Also

Reference

Floor Class


Floor.Y Field

FloorY Field

The Y coordinate of the normal vector.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Y

Field Value

Type: Single
See Also

Reference

Floor Class


Floor.Z Field

FloorZ Field

The Z coordinate of the normal vector.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Z

Field Value

Type: Single
See Also

Reference

Floor Class


FloorFrameSource Class

Represents a Floor frame source.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureFloorFrameSource

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class FloorFrameSource

The FloorFrameSource type exposes the following members.

Constructors
 | Name | Description
Public method | FloorFrameSource | Initializes a new instance of the FloorFrameSource class
Top
Properties
 | Name | Description
Public property | Floor | The floor plane data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


FloorFrameSource Constructor

Initializes a new instance of the FloorFrameSource class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public FloorFrameSource()
See Also

Reference

FloorFrameSource Class


FloorFrameSource Properties

The FloorFrameSource type exposes the following members.

Properties
 | Name | Description
Public property | Floor | The floor plane data.
Top
See Also

Reference

FloorFrameSource Class


FloorFrameSource.Floor Property

FloorFrameSourceFloor Property

The floor plane data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Floor Floor { get; }

Property Value

Type: Floor
See Also

Reference

FloorFrameSource Class


FloorFrameSource Methods

The FloorFrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FloorFrameSource Class


Frame Class

Encapsulates Azure Kinect frame data.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureFrame

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Frame

The Frame type exposes the following members.

Constructors
 | Name | Description
Public method | Frame | Initializes a new instance of the Frame class
Top
Properties
 | Name | Description
Public property | BodyFrameSource | The body frame data.
Public property | ColorFrameSource | The color frame data.
Public property | DepthFrameSource | The depth frame data.
Public property | FloorFrameSource | The floor frame data.
Public property | IMUFrameSource | The IMU frame data.
Public property | Timestamp | The unique timestamp of the frame.
Public property | UserFrameSource | The user-index map frame data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Frame Constructor

Initializes a new instance of the Frame class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Frame()
See Also

Reference

Frame Class


Frame Properties

The Frame type exposes the following members.

Properties
 | Name | Description
Public property | BodyFrameSource | The body frame data.
Public property | ColorFrameSource | The color frame data.
Public property | DepthFrameSource | The depth frame data.
Public property | FloorFrameSource | The floor frame data.
Public property | IMUFrameSource | The IMU frame data.
Public property | Timestamp | The unique timestamp of the frame.
Public property | UserFrameSource | The user-index map frame data.
Top
See Also

Reference

Frame Class


Frame.BodyFrameSource Property

FrameBodyFrameSource Property

The body frame data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public BodyFrameSource BodyFrameSource { get; }

Property Value

Type: BodyFrameSource
See Also

Reference

Frame Class


Frame.ColorFrameSource Property

FrameColorFrameSource Property

The color frame data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ColorFrameSource ColorFrameSource { get; }

Property Value

Type: ColorFrameSource
See Also

Reference

Frame Class


Frame.DepthFrameSource Property

FrameDepthFrameSource Property

The depth frame data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DepthFrameSource DepthFrameSource { get; }

Property Value

Type: DepthFrameSource
See Also

Reference

Frame Class


Frame.FloorFrameSource Property

FrameFloorFrameSource Property

The floor frame data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public FloorFrameSource FloorFrameSource { get; }

Property Value

Type: FloorFrameSource
See Also

Reference

Frame Class


Frame.IMUFrameSource Property

FrameIMUFrameSource Property

The IMU frame data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IMUFrameSource IMUFrameSource { get; }

Property Value

Type: IMUFrameSource
See Also

Reference

Frame Class


Frame.Timestamp Property

FrameTimestamp Property

The unique timestamp of the frame.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DateTime Timestamp { get; }

Property Value

Type: DateTime
See Also

Reference

Frame Class


Frame.UserFrameSource Property

FrameUserFrameSource Property

The user-index map frame data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public UserFrameSource UserFrameSource { get; }

Property Value

Type: UserFrameSource
See Also

Reference

Frame Class


Frame Methods

The Frame type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Frame Class


FramesPerSecond Enumeration

Color and depth sensor frame rate.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum FramesPerSecond
Members
Member name | Value | Description
FPS_5 | 0 | 5 FPS.
FPS_15 | 1 | 15 FPS.
FPS_30 | 2 | 30 FPS.
See Also

Reference


IMU Class

Represents and Inertial Measurement Unit (e.g. Accelerometer/Gyroscope).
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureIMU

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class IMU

The IMU type exposes the following members.

Constructors
 | Name | Description
Public method | IMU | Creates an empty IMU.
Public method | IMU(IMU) | Clones an IMU.
Top
Properties
 | Name | Description
Public property | Sample | The sample of the IMU (in meters per second squared).
Public property | Timestamp | The timestamp of the unit.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pitch | Returns the rotation of the camera around the X axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.
Public method | Roll | Returns the rotation of the camera around the Z axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.
Public method | Tilt | Returns the tilt of the camera. Positive: the camera faces upwards. Negative: the camera faces downwards. Zero: the camera is straight.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Yaw | Returns the rotation of the camera around the Y axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.
Top
See Also

Reference


IMU Constructor

Overload List
 | Name | Description
Public method | IMU | Creates an empty IMU.
Public method | IMU(IMU) | Clones an IMU.
Top
See Also

Reference

IMU Class


IMU Constructor

Creates an empty IMU.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IMU()
See Also

Reference

IMU Class
IMU Overload


IMU Constructor (IMU)

Clones an IMU.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IMU(
    IMU other
)

Parameters

other
Type: LightBuzz.Kinect4AzureIMU
The IMU to clone.
See Also

Reference

IMU Class
IMU Overload


IMU Properties

The IMU type exposes the following members.

Properties
 | Name | Description
Public property | Sample | The sample of the IMU (in meters per second squared).
Public property | Timestamp | The timestamp of the unit.
Top
See Also

Reference

IMU Class


IMU.Sample Property

IMUSample Property

The sample of the IMU (in meters per second squared).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector3D Sample { get; }

Property Value

Type: Vector3D
See Also

Reference

IMU Class


IMU.Timestamp Property

IMUTimestamp Property

The timestamp of the unit.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TimeSpan Timestamp { get; }

Property Value

Type: TimeSpan
See Also

Reference

IMU Class


IMU Methods

The IMU type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pitch | Returns the rotation of the camera around the X axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.
Public method | Roll | Returns the rotation of the camera around the Z axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.
Public method | Tilt | Returns the tilt of the camera. Positive: the camera faces upwards. Negative: the camera faces downwards. Zero: the camera is straight.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Yaw | Returns the rotation of the camera around the Y axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.
Top
See Also

Reference

IMU Class


IMU.Pitch Method

IMUPitch Method

Returns the rotation of the camera around the X axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Pitch(
    bool degrees = true
)

Parameters

degrees (Optional)
Type: SystemBoolean
The measurement unit (degrees or radians).

Return Value

Type: Single
The Pitch rotation angle.
See Also

Reference

IMU Class


IMU.Roll Method

IMURoll Method

Returns the rotation of the camera around the Z axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Roll(
    bool degrees = true
)

Parameters

degrees (Optional)
Type: SystemBoolean
The measurement unit (degrees or radians).

Return Value

Type: Single
The Pitch rotation angle.
See Also

Reference

IMU Class


IMU.Tilt Method

IMUTilt Method

Returns the tilt of the camera. Positive: the camera faces upwards. Negative: the camera faces downwards. Zero: the camera is straight.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Tilt(
    Axis axis,
    bool degrees = true
)

Parameters

axis
Type: Axis
The axis to get the tilt from.
degrees (Optional)
Type: SystemBoolean
The measurement unit (degrees or radians).

Return Value

Type: Single
The tilt of the camera.
See Also

Reference

IMU Class


IMU.Yaw Method

IMUYaw Method

Returns the rotation of the camera around the Y axis. Positive: the camera faces downwards. Negative: the camera faces upwards. Zero: the camera is straight.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Yaw(
    bool degrees = true
)

Parameters

degrees (Optional)
Type: SystemBoolean
The measurement unit (degrees or radians).

Return Value

Type: Single
The Pitch rotation angle.
See Also

Reference

IMU Class


IMUFrameSource Class

Represents an Inertial Measurement Unit (IMU: Accelerometer and Gyroscope) frame source.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureIMUFrameSource

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class IMUFrameSource

The IMUFrameSource type exposes the following members.

Constructors
 | Name | Description
Public method | IMUFrameSource | Initializes a new instance of the IMUFrameSource class
Top
Properties
 | Name | Description
Public property | Accelerometer | The Accelerometer data.
Public property | Gyroscope | The Gyroscope data.
Public property | Temperature | The temperature of the unit (in Celsius).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


IMUFrameSource Constructor

Initializes a new instance of the IMUFrameSource class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IMUFrameSource()
See Also

Reference

IMUFrameSource Class


IMUFrameSource Properties

The IMUFrameSource type exposes the following members.

Properties
 | Name | Description
Public property | Accelerometer | The Accelerometer data.
Public property | Gyroscope | The Gyroscope data.
Public property | Temperature | The temperature of the unit (in Celsius).
Top
See Also

Reference

IMUFrameSource Class


IMUFrameSource.Accelerometer Property

IMUFrameSourceAccelerometer Property

The Accelerometer data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IMU Accelerometer { get; }

Property Value

Type: IMU
See Also

Reference

IMUFrameSource Class


IMUFrameSource.Gyroscope Property

IMUFrameSourceGyroscope Property

The Gyroscope data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IMU Gyroscope { get; }

Property Value

Type: IMU
See Also

Reference

IMUFrameSource Class


IMUFrameSource.Temperature Property

IMUFrameSourceTemperature Property

The temperature of the unit (in Celsius).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Temperature { get; }

Property Value

Type: Single
See Also

Reference

IMUFrameSource Class


IMUFrameSource Methods

The IMUFrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IMUFrameSource Class


Joint Class

Represents a human body joint.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureJoint

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Joint

The Joint type exposes the following members.

Constructors
 | Name | Description
Public method | Joint | Initializes a new instance of the Joint class
Top
Properties
 | Name | Description
Public property | JointType | The type of the joint.
Public property | Orientation | The orientation of the joint.
Public property | Position | The position of the joint in the 3D world space.
Public property | PositionColor | The position of the joint in the 2D color space.
Public property | PositionDepth | The position of the joint in the 2D depth space.
Public property | TrackingState | The tracking state of the joint.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Joint Constructor

Initializes a new instance of the Joint class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Joint()
See Also

Reference

Joint Class


Joint Properties

The Joint type exposes the following members.

Properties
 | Name | Description
Public property | JointType | The type of the joint.
Public property | Orientation | The orientation of the joint.
Public property | Position | The position of the joint in the 3D world space.
Public property | PositionColor | The position of the joint in the 2D color space.
Public property | PositionDepth | The position of the joint in the 2D depth space.
Public property | TrackingState | The tracking state of the joint.
Top
See Also

Reference

Joint Class


Joint.JointType Property

JointJointType Property

The type of the joint.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public JointType JointType { get; }

Property Value

Type: JointType
See Also

Reference

Joint Class


Joint.Orientation Property

JointOrientation Property

The orientation of the joint.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector4D Orientation { get; }

Property Value

Type: Vector4D
See Also

Reference

Joint Class


Joint.Position Property

JointPosition Property

The position of the joint in the 3D world space.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector3D Position { get; }

Property Value

Type: Vector3D
See Also

Reference

Joint Class


Joint.PositionColor Property

JointPositionColor Property

The position of the joint in the 2D color space.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector2D PositionColor { get; }

Property Value

Type: Vector2D
See Also

Reference

Joint Class


Joint.PositionDepth Property

JointPositionDepth Property

The position of the joint in the 2D depth space.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector2D PositionDepth { get; }

Property Value

Type: Vector2D
See Also

Reference

Joint Class


Joint.TrackingState Property

JointTrackingState Property

The tracking state of the joint.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TrackingState TrackingState { get; }

Property Value

Type: TrackingState
See Also

Reference

Joint Class


Joint Methods

The Joint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Joint Class


JointType Enumeration

Represents the Azure Kinect joint types.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum JointType
Members
Member name | Value | Description
Pelvis | 0 | Pelvis
SpineNaval | 1 | Spine Naval
SpineChest | 2 | Spine Chest
Neck | 3 | Neck
ClavicleLeft | 4 | Left Clavicle
ShoulderLeft | 5 | Left Shoulder
ElbowLeft | 6 | Left Elbow
WristLeft | 7 | Left Wrist
HandLeft | 8 | Left Hand
HandtipLeft | 9 | Left Hand-tip
ThumbLeft | 10 | Left Thumb
ClavicleRight | 11 | Right Clavicle
ShoulderRight | 12 | Right Shoulder
ElbowRight | 13 | Right Elbow
WristRight | 14 | Right Wrist
HandRight | 15 | Right Hand
HandtipRight | 16 | Right Hand-tip
ThumbRight | 17 | Right Thumb
HipLeft | 18 | Left Hip
KneeLeft | 19 | Left Knee
AnkleLeft | 20 | Left Ankle
FootLeft | 21 | Left Foot
HipRight | 22 | Right Hip
KneeRight | 23 | Right Knee
AnkleRight | 24 | Right Ankle
FootRight | 25 | Right Foot
Head | 26 | Head
Nose | 27 | Nose
EyeLeft | 28 | Left Eye
EarLeft | 29 | Left Ear
EyeRight | 30 | Right Eye
EarRight | 31 | Right Ear
See Also

Reference


Jpeg Class

JPEG encoding and decoding.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureJpeg

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static class Jpeg

The Jpeg type exposes the following members.

Methods
Name | Description
Decode | Decodes the compressed JPEG data to raw RGB data.
Encode | Encodes the raw RGBA data to JPEG.
Top
See Also

Reference


Jpeg Methods

The Jpeg type exposes the following members.

Methods
Name | Description
Decode | Decodes the compressed JPEG data to raw RGB data.
Encode | Encodes the raw RGBA data to JPEG.
Top
See Also

Reference

Jpeg Class


Jpeg.Decode Method

JpegDecode Method

Decodes the compressed JPEG data to raw RGB data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static byte[] Decode(
    byte[] jpegData,
    int width,
    int height
)

Parameters

jpegData
Type: SystemByte
The compressed JPEG data.
width
Type: SystemInt32
The width of the JPEG image.
height
Type: SystemInt32
The height of the JPEG image.

Return Value

Type: Byte
The raw uncompressed RGB array.
See Also

Reference

Jpeg Class


Jpeg.Encode Method

JpegEncode Method

Encodes the raw RGBA data to JPEG.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static byte[] Encode(
    byte[] rawData,
    int width,
    int height,
    int quality = 75
)

Parameters

rawData
Type: SystemByte
The uncompressed raw RGBA data.
width
Type: SystemInt32
The width of the image.
height
Type: SystemInt32
The height of the image.
quality (Optional)
Type: SystemInt32
The JPEG encoding quality (0 - 100).

Return Value

Type: Byte
The compressed JPEG data.
See Also

Reference

Jpeg Class


KinectSensor Class

Represents an Azure Kinect sensor device.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureKinectSensor

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public sealed class KinectSensor

The KinectSensor type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | The configuration parameters of the sensor.
Public property | CoordinateMapper | The coordinate mapper.
 | Count | Returns the number of the connect Kinect devices.
Public property | IsOpen | Specifies whether the sensor is open and streaming.
Top
Methods
 | Name | Description
Public method | Close | Closes the sensor.
 | Create(Int32) | Creates a new KinectSensor with the specified device index and the default configuration parameters.
 | Create(Configuration) | Creates a new KinectSensor with the specified configuration parameters.
Public method | Equals | Specifies whether two instances of a KinectSensor device refer to the same physical device. (Overrides ObjectEquals(Object).)
 | GetDefault | Creates a new KinectSensor with the default configuration parameters and the default device index.
Public method | GetHashCode | Serves as the hash function for the KinectSensor type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Open | Opens the sensor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Returns the latest frame data.
Top
See Also

Reference


KinectSensor Properties

The KinectSensor type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | The configuration parameters of the sensor.
Public property | CoordinateMapper | The coordinate mapper.
 | Count | Returns the number of the connect Kinect devices.
Public property | IsOpen | Specifies whether the sensor is open and streaming.
Top
See Also

Reference

KinectSensor Class


KinectSensor.Configuration Property

KinectSensorConfiguration Property

The configuration parameters of the sensor.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Configuration Configuration { get; }

Property Value

Type: Configuration
See Also

Reference

KinectSensor Class


KinectSensor.CoordinateMapper Property

KinectSensorCoordinateMapper Property

The coordinate mapper.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public CoordinateMapper CoordinateMapper { get; }

Property Value

Type: CoordinateMapper
See Also

Reference

KinectSensor Class


KinectSensor.Count Property

KinectSensorCount Property

Returns the number of the connect Kinect devices.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static int Count { get; }

Property Value

Type: Int32
See Also

Reference

KinectSensor Class


KinectSensor.IsOpen Property

KinectSensorIsOpen Property

Specifies whether the sensor is open and streaming.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool IsOpen { get; }

Property Value

Type: Boolean
See Also

Reference

KinectSensor Class


KinectSensor Methods

The KinectSensor type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the sensor.
 | Create(Int32) | Creates a new KinectSensor with the specified device index and the default configuration parameters.
 | Create(Configuration) | Creates a new KinectSensor with the specified configuration parameters.
Public method | Equals | Specifies whether two instances of a KinectSensor device refer to the same physical device. (Overrides ObjectEquals(Object).)
 | GetDefault | Creates a new KinectSensor with the default configuration parameters and the default device index.
Public method | GetHashCode | Serves as the hash function for the KinectSensor type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Open | Opens the sensor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Returns the latest frame data.
Top
See Also

Reference

KinectSensor Class


KinectSensor.Close Method

KinectSensorClose Method

Closes the sensor.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Close()
See Also

Reference

KinectSensor Class


KinectSensor.Create Method

KinectSensorCreate Method

Overload List
Name | Description
Create(Int32) | Creates a new KinectSensor with the specified device index and the default configuration parameters.
Create(Configuration) | Creates a new KinectSensor with the specified configuration parameters.
Top
See Also

Reference

KinectSensor Class


KinectSensor.Create Method (Int32)

KinectSensorCreate Method (Int32)

Creates a new KinectSensor with the specified device index and the default configuration parameters.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static KinectSensor Create(
    int index
)

Parameters

index
Type: SystemInt32
The index of the device (if more than 1 devices are connected).

Return Value

Type: KinectSensor
A KinectSensor device or null.
See Also

Reference

KinectSensor Class
Create Overload


KinectSensor.Create Method (Configuration)

KinectSensorCreate Method (Configuration)

Creates a new KinectSensor with the specified configuration parameters.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static KinectSensor Create(
    Configuration configuration
)

Parameters

configuration
Type: LightBuzz.Kinect4AzureConfiguration
The configuration parameters for the sensor.

Return Value

Type: KinectSensor
A KinectSensor device or null.
See Also

Reference

KinectSensor Class
Create Overload


KinectSensor.Equals Method

KinectSensorEquals Method

Specifies whether two instances of a KinectSensor device refer to the same physical device.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The device to compare with.

Return Value

Type: Boolean
True if both instances refer to the same device. False otherwise.
See Also

Reference

KinectSensor Class


KinectSensor.GetDefault Method

KinectSensorGetDefault Method

Creates a new KinectSensor with the default configuration parameters and the default device index.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static KinectSensor GetDefault()

Return Value

Type: KinectSensor
A KinectSensor device or null.
See Also

Reference

KinectSensor Class


KinectSensor.GetHashCode Method

KinectSensorGetHashCode Method

Serves as the hash function for the KinectSensor type.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
The hash code value.
See Also

Reference

KinectSensor Class


KinectSensor.Open Method

KinectSensorOpen Method

Opens the sensor.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Open()
See Also

Reference

KinectSensor Class


KinectSensor.Update Method

KinectSensorUpdate Method

Returns the latest frame data.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Frame Update()

Return Value

Type: Frame
The latest frame data.
See Also

Reference

KinectSensor Class


TrackingState Enumeration

The tracking state.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum TrackingState
Members
Member name | Value | Description
None | 0 | The joint is out of range (too far from depth camera).
Low | 1 | The joint is not observed (likely due to occlusion), predicted joint pose.
Medium | 2 | Medium confidence in joint pose. Current SDK will only provide joints up to this confidence level.
High | 3 | High confidence in joint pose. Placeholder for future SDK.
Count | 4 | The total number of tracking states.
See Also

Reference


UserFrameSource Class

Represents a User Index Map frame source.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4AzureUserFrameSource

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class UserFrameSource

The UserFrameSource type exposes the following members.

Constructors
 | Name | Description
Public method | UserFrameSource | Initializes a new instance of the UserFrameSource class
Top
Properties
 | Name | Description
Public property | BytesPerPixel | The number of bytes per pixel.
Public property | Data | The buffer (byte array) of the frame.
Public property | Height | The height of the frame (in pixels).
Public property | Stride | The stride of the frame.
Public property | Width | The width of the frame (in pixels).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Background | Indication that a point belongs to the background.
Top
See Also

Reference


UserFrameSource Constructor

Initializes a new instance of the UserFrameSource class

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public UserFrameSource()
See Also

Reference

UserFrameSource Class


UserFrameSource Properties

The UserFrameSource type exposes the following members.

Properties
 | Name | Description
Public property | BytesPerPixel | The number of bytes per pixel.
Public property | Data | The buffer (byte array) of the frame.
Public property | Height | The height of the frame (in pixels).
Public property | Stride | The stride of the frame.
Public property | Width | The width of the frame (in pixels).
Top
See Also

Reference

UserFrameSource Class


UserFrameSource.BytesPerPixel Property

UserFrameSourceBytesPerPixel Property

The number of bytes per pixel.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int BytesPerPixel { get; }

Property Value

Type: Int32
See Also

Reference

UserFrameSource Class


UserFrameSource.Data Property

UserFrameSourceData Property

The buffer (byte array) of the frame.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public byte[] Data { get; }

Property Value

Type: Byte
See Also

Reference

UserFrameSource Class


UserFrameSource.Height Property

UserFrameSourceHeight Property

The height of the frame (in pixels).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Height { get; }

Property Value

Type: Int32
See Also

Reference

UserFrameSource Class


UserFrameSource.Stride Property

UserFrameSourceStride Property

The stride of the frame.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Stride { get; }

Property Value

Type: Int32
See Also

Reference

UserFrameSource Class


UserFrameSource.Width Property

UserFrameSourceWidth Property

The width of the frame (in pixels).

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Width { get; }

Property Value

Type: Int32
See Also

Reference

UserFrameSource Class


UserFrameSource Methods

The UserFrameSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserFrameSource Class


UserFrameSource Fields

The UserFrameSource type exposes the following members.

Fields
Name | Description
Background | Indication that a point belongs to the background.
Top
See Also

Reference

UserFrameSource Class


UserFrameSource.Background Field

UserFrameSourceBackground Field

Indication that a point belongs to the background.

Namespace: LightBuzz.Kinect4Azure
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const byte Background = 255

Field Value

Type: Byte
See Also

Reference

UserFrameSource Class


LightBuzz.Kinect4Azure.Avateering Namespace

Avatar animation in the 3D and 2D space.
Classes
 | Class | Description
Public class | Avatar | Represents an animatable avatar.
Public class | Bone | Represents an avatar bone.
Public class | Jump | Functions that determine the jump.


Avatar Class

Represents an animatable avatar.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.AvateeringAvatar

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class Avatar

The Avatar type exposes the following members.

Constructors
 | Name | Description
Public method | Avatar | Initializes a new instance of the Avatar class
Top
Properties
 | Name | Description
Public property | MatchScale | Scales the model to match the scale of the body detected.
Public property | SmoothDelta | The motion smoothing factor (0.0 - 1.0).
Public property | UpdatePose | Updates the avatar's bones.
Public property | UseWorldPosition | Specifies whether the avatar will move in the 3D world space.
Top
Methods
 | Name | Description
Public method | ApplyScale | Applies scale to the Avatar Root.
Public method | ApplyScaleAtBones | Applies scale to the highest hierarchy bone.
Protected method | CalculateOrientations | Calculations are done by finding a normal, a destination and the offset to the original rotation. The normal defines the UP vector in order to rotate the joints based on an axis. The destination is where the joint should "look at". The hard coded offset of each joint rotates the joint to the correct place from its original rotation from the T-Pose.
Protected method | CalculateScale | Calculates and applies the scale to the avatar to meet the body.
Public method | DoTPose | Forces model to T-Pose.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindHighestHieararchyBone | Center of mass will be used to calculate offset.
Public method | GetBone | Finds and returns the bone of the Animator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Caches animator bones for rotation.
Public method | Initialize(GameObject) | Assigns a new root GameObject for the avatar. Caches animator bones for rotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PositionAt | Sets the position of the vatar at point.
Public method | PositionBonesAtPoint | Sets the position of the highest hierarchy bone at the position, thus moving the whole avatar.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Initialises the avatar if it has not been initialised. Updates joints orientation and position.
Protected method | UpdateJump | Calculates jump and crouch.
Top
See Also

Reference

LightBuzz.Kinect4Azure.Avateering Namespace


Avatar Constructor

Initializes a new instance of the Avatar class

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Avatar()
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar Properties

The Avatar type exposes the following members.

Properties
 | Name | Description
Public property | MatchScale | Scales the model to match the scale of the body detected.
Public property | SmoothDelta | The motion smoothing factor (0.0 - 1.0).
Public property | UpdatePose | Updates the avatar's bones.
Public property | UseWorldPosition | Specifies whether the avatar will move in the 3D world space.
Top
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.MatchScale Property

AvatarMatchScale Property

Scales the model to match the scale of the body detected.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool MatchScale { get; set; }

Property Value

Type: Boolean
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.SmoothDelta Property

AvatarSmoothDelta Property

The motion smoothing factor (0.0 - 1.0).

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float SmoothDelta { get; set; }

Property Value

Type: Single
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.UpdatePose Property

AvatarUpdatePose Property

Updates the avatar's bones.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool UpdatePose { get; set; }

Property Value

Type: Boolean
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.UseWorldPosition Property

AvatarUseWorldPosition Property

Specifies whether the avatar will move in the 3D world space.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool UseWorldPosition { get; set; }

Property Value

Type: Boolean
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar Methods

The Avatar type exposes the following members.

Methods
 | Name | Description
Public method | ApplyScale | Applies scale to the Avatar Root.
Public method | ApplyScaleAtBones | Applies scale to the highest hierarchy bone.
Protected method | CalculateOrientations | Calculations are done by finding a normal, a destination and the offset to the original rotation. The normal defines the UP vector in order to rotate the joints based on an axis. The destination is where the joint should "look at". The hard coded offset of each joint rotates the joint to the correct place from its original rotation from the T-Pose.
Protected method | CalculateScale | Calculates and applies the scale to the avatar to meet the body.
Public method | DoTPose | Forces model to T-Pose.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindHighestHieararchyBone | Center of mass will be used to calculate offset.
Public method | GetBone | Finds and returns the bone of the Animator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Caches animator bones for rotation.
Public method | Initialize(GameObject) | Assigns a new root GameObject for the avatar. Caches animator bones for rotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PositionAt | Sets the position of the vatar at point.
Public method | PositionBonesAtPoint | Sets the position of the highest hierarchy bone at the position, thus moving the whole avatar.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Initialises the avatar if it has not been initialised. Updates joints orientation and position.
Protected method | UpdateJump | Calculates jump and crouch.
Top
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.ApplyScale Method

AvatarApplyScale Method

Applies scale to the Avatar Root.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void ApplyScale(
    float newScale
)

Parameters

newScale
Type: SystemSingle

[Missing <param name="newScale"/> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.ApplyScale(System.Single)"]

See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.ApplyScaleAtBones Method

AvatarApplyScaleAtBones Method

Applies scale to the highest hierarchy bone.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool ApplyScaleAtBones(
    float newScale
)

Parameters

newScale
Type: SystemSingle

[Missing <param name="newScale"/> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.ApplyScaleAtBones(System.Single)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.ApplyScaleAtBones(System.Single)"]

See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.CalculateOrientations Method

AvatarCalculateOrientations Method

Calculations are done by finding a normal, a destination and the offset to the original rotation. The normal defines the UP vector in order to rotate the joints based on an axis. The destination is where the joint should "look at". The hard coded offset of each joint rotates the joint to the correct place from its original rotation from the T-Pose.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected void CalculateOrientations(
    Body body
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody

[Missing <param name="body"/> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.CalculateOrientations(LightBuzz.Kinect4Azure.Body)"]

See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.CalculateScale Method

AvatarCalculateScale Method

Calculates and applies the scale to the avatar to meet the body.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected void CalculateScale(
    Body body
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody

[Missing <param name="body"/> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.CalculateScale(LightBuzz.Kinect4Azure.Body)"]

See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.DoTPose Method

AvatarDoTPose Method

Forces model to T-Pose.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void DoTPose()
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.FindHighestHieararchyBone Method

AvatarFindHighestHieararchyBone Method

Center of mass will be used to calculate offset.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected JointType FindHighestHieararchyBone()

Return Value

Type: JointType

[Missing <returns> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.FindHighestHieararchyBone"]

See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.GetBone Method

AvatarGetBone Method

Finds and returns the bone of the Animator.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Bone GetBone(
    HumanBodyBones humanBodyBone
)

Parameters

humanBodyBone
Type: HumanBodyBones

[Missing <param name="humanBodyBone"/> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.GetBone(UnityEngine.HumanBodyBones)"]

Return Value

Type: Bone

[Missing <returns> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.GetBone(UnityEngine.HumanBodyBones)"]

See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.Initialize Method

AvatarInitialize Method

Overload List
 | Name | Description
Public method | Initialize | Caches animator bones for rotation.
Public method | Initialize(GameObject) | Assigns a new root GameObject for the avatar. Caches animator bones for rotation.
Top
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.Initialize Method

AvatarInitialize Method

Caches animator bones for rotation.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Initialize()
See Also

Reference

Avatar Class
Initialize Overload
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.Initialize Method (GameObject)

AvatarInitialize Method (GameObject)

Assigns a new root GameObject for the avatar. Caches animator bones for rotation.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Initialize(
    GameObject newAvatarRoot
)

Parameters

newAvatarRoot
Type: GameObject
The new root GameObject from the avatar to use.
See Also

Reference

Avatar Class
Initialize Overload
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.PositionAt Method

AvatarPositionAt Method

Sets the position of the vatar at point.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void PositionAt(
    Vector3 point
)

Parameters

point
Type: Vector3
The new position of the avatar.
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.PositionBonesAtPoint Method

AvatarPositionBonesAtPoint Method

Sets the position of the highest hierarchy bone at the position, thus moving the whole avatar.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool PositionBonesAtPoint(
    Vector3 point
)

Parameters

point
Type: Vector3
The new position of the root bone.

Return Value

Type: Boolean
True if the bone was positioned. False if it failed.
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.Update Method

AvatarUpdate Method

Initialises the avatar if it has not been initialised. Updates joints orientation and position.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Update(
    Body body,
    Floor floor = null
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody
The body data to feed the avatar with.
floor (Optional)
Type: LightBuzz.Kinect4AzureFloor
The floor data.
See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Avatar.UpdateJump Method

AvatarUpdateJump Method

Calculates jump and crouch.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected void UpdateJump(
    Body body,
    Floor floor
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody

[Missing <param name="body"/> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.UpdateJump(LightBuzz.Kinect4Azure.Body,LightBuzz.Kinect4Azure.Floor)"]

floor
Type: LightBuzz.Kinect4AzureFloor

[Missing <param name="floor"/> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Avatar.UpdateJump(LightBuzz.Kinect4Azure.Body,LightBuzz.Kinect4Azure.Floor)"]

See Also

Reference

Avatar Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone Class

Represents an avatar bone.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.AvateeringBone

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Bone

The Bone type exposes the following members.

Properties
 | Name | Description
Public property | OriginalPosition | The original position of the bone.
Public property | OriginalRotation | The original rotation of the bone.
Public property | Transform | The transform of the bone.
Top
Methods
 | Name | Description
Public method | CalibrateOriginalRotation | Calibrate the original bone rotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the rotation of the current bone.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePosition | Updates the position of the current bone.
Public method | UpdateRotation | Updates the rotation of the current bone.
Top
See Also

Reference

LightBuzz.Kinect4Azure.Avateering Namespace


Bone Properties

The Bone type exposes the following members.

Properties
 | Name | Description
Public property | OriginalPosition | The original position of the bone.
Public property | OriginalRotation | The original rotation of the bone.
Public property | Transform | The transform of the bone.
Top
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone.OriginalPosition Property

BoneOriginalPosition Property

The original position of the bone.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Vector3 OriginalPosition { get; }

Property Value

Type: Vector3
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone.OriginalRotation Property

BoneOriginalRotation Property

The original rotation of the bone.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Quaternion OriginalRotation { get; }

Property Value

Type: Quaternion
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone.Transform Property

BoneTransform Property

The transform of the bone.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Transform Transform { get; }

Property Value

Type: Transform
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone Methods

The Bone type exposes the following members.

Methods
 | Name | Description
Public method | CalibrateOriginalRotation | Calibrate the original bone rotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the rotation of the current bone.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePosition | Updates the position of the current bone.
Public method | UpdateRotation | Updates the rotation of the current bone.
Top
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone.CalibrateOriginalRotation Method

BoneCalibrateOriginalRotation Method

Calibrate the original bone rotation.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void CalibrateOriginalRotation()
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone.Reset Method

BoneReset Method

Resets the rotation of the current bone.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Reset()
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone.UpdatePosition Method

BoneUpdatePosition Method

Updates the position of the current bone.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void UpdatePosition(
    Vector3 newPosition
)

Parameters

newPosition
Type: Vector3
The new bone position.
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Bone.UpdateRotation Method

BoneUpdateRotation Method

Updates the rotation of the current bone.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void UpdateRotation(
    Quaternion newRotation,
    float smoothDelta
)

Parameters

newRotation
Type: Quaternion
The new rotation.
smoothDelta
Type: SystemSingle
The motion smoothing factor (0.0 - 1.0)
See Also

Reference

Bone Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump Class

Functions that determine the jump.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.AvateeringJump

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Jump

The Jump type exposes the following members.

Constructors
 | Name | Description
Public method | Jump | Initializes a new instance of the Jump class
Top
Properties
 | Name | Description
Public property | IsJumping | True if the body is jumping. False if not.
Public property | JumpHeight | Jump height in meters.
Public property | LowestJoint | Indicates the lowest joint in the body.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLowestAnkle | Finds the lowest Y of the feet.
Protected method | FindLowestFoot | Finds the lowest Y of the feet.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Finds if the body has jump and how much. Updates the variable LowestJoint.
Public method | UpdateLowestJoint | Updates the variable LowestJoint.
Top
Fields
Name | Description
Tolerance | Offset for the lowest joint from the floor (represents the minimum height of the joint).
Top
See Also

Reference

LightBuzz.Kinect4Azure.Avateering Namespace


Jump Constructor

Initializes a new instance of the Jump class

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Jump()
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump Properties

The Jump type exposes the following members.

Properties
 | Name | Description
Public property | IsJumping | True if the body is jumping. False if not.
Public property | JumpHeight | Jump height in meters.
Public property | LowestJoint | Indicates the lowest joint in the body.
Top
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump.IsJumping Property

JumpIsJumping Property

True if the body is jumping. False if not.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool IsJumping { get; protected set; }

Property Value

Type: Boolean
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump.JumpHeight Property

JumpJumpHeight Property

Jump height in meters.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float JumpHeight { get; protected set; }

Property Value

Type: Single
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump.LowestJoint Property

JumpLowestJoint Property

Indicates the lowest joint in the body.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Joint LowestJoint { get; protected set; }

Property Value

Type: Joint
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump Methods

The Jump type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLowestAnkle | Finds the lowest Y of the feet.
Protected method | FindLowestFoot | Finds the lowest Y of the feet.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Finds if the body has jump and how much. Updates the variable LowestJoint.
Public method | UpdateLowestJoint | Updates the variable LowestJoint.
Top
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump.FindLowestAnkle Method

JumpFindLowestAnkle Method

Finds the lowest Y of the feet.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected Vector3D FindLowestAnkle(
    Body body
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody
Position in y.

Return Value

Type: Vector3D

[Missing <returns> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Jump.FindLowestAnkle(LightBuzz.Kinect4Azure.Body)"]

See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump.FindLowestFoot Method

JumpFindLowestFoot Method

Finds the lowest Y of the feet.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected Vector3D FindLowestFoot(
    Body body
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody
Position in y.

Return Value

Type: Vector3D

[Missing <returns> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Jump.FindLowestFoot(LightBuzz.Kinect4Azure.Body)"]

See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump.Update Method

JumpUpdate Method

Finds if the body has jump and how much. Updates the variable LowestJoint.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Update(
    Body body,
    Floor floor
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody
The body to calculate if it jumped.
floor
Type: LightBuzz.Kinect4AzureFloor
The floor to calculate the jump.

Return Value

Type:
True if the body is jumping. False if not.
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump.UpdateLowestJoint Method

JumpUpdateLowestJoint Method

Updates the variable LowestJoint.

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void UpdateLowestJoint(
    Body body
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody

[Missing <param name="body"/> documentation for "M:LightBuzz.Kinect4Azure.Avateering.Jump.UpdateLowestJoint(LightBuzz.Kinect4Azure.Body)"]

See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump Fields

The Jump type exposes the following members.

Fields
Name | Description
Tolerance | Offset for the lowest joint from the floor (represents the minimum height of the joint).
Top
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


Jump.Tolerance Field

JumpTolerance Field

Offset for the lowest joint from the floor (represents the minimum height of the joint).

Namespace: LightBuzz.Kinect4Azure.Avateering
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const float Tolerance = 0.1f

Field Value

Type: Single
See Also

Reference

Jump Class
LightBuzz.Kinect4Azure.Avateering Namespace


LightBuzz.Kinect4Azure.Video Namespace

Video recording and playback module.
Classes
 | Class | Description
Public class | FileExtensions | The common file extensions used in the LightBuzz Body-Tracking framework.
Public class | FileNames | The common video file name.s
Public class | VideoConfiguration | Video configuration settings.
Public class | VideoHelper | Video utility methods for importing and exporting data.
Public class | VideoPlayer | Loads recorded frames (Color, Depth, and Body data).
Public class | VideoRecorder | Records Color, Depth, and Body data.


FileExtensions Class

The common file extensions used in the LightBuzz Body-Tracking framework.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.VideoFileExtensions

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static class FileExtensions

The FileExtensions type exposes the following members.

Fields
Name | Description
BIN | BIN
Body | Raw body data.
Color | Raw color data.
Configuration | Configuration settings.
Depth | Raw depth data.
Floor | Raw floor data.
IMU | Raw IMU data.
JPG | JPEG
JSON | JSON
LBZ | LBZ
META | META
PNG | PNG
Timestamps | Timestamp data.
Top
See Also

Reference

LightBuzz.Kinect4Azure.Video Namespace


FileExtensions Fields

The FileExtensions type exposes the following members.

Fields
Name | Description
BIN | BIN
Body | Raw body data.
Color | Raw color data.
Configuration | Configuration settings.
Depth | Raw depth data.
Floor | Raw floor data.
IMU | Raw IMU data.
JPG | JPEG
JSON | JSON
LBZ | LBZ
META | META
PNG | PNG
Timestamps | Timestamp data.
Top
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.BIN Field

FileExtensionsBIN Field

BIN

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string BIN = ".bin"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.Body Field

FileExtensionsBody Field

Raw body data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string Body = ".body"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.Color Field

FileExtensionsColor Field

Raw color data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string Color = ".color"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.Configuration Field

FileExtensionsConfiguration Field

Configuration settings.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string Configuration = ".configuration"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.Depth Field

FileExtensionsDepth Field

Raw depth data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string Depth = ".depth"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.Floor Field

FileExtensionsFloor Field

Raw floor data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string Floor = ".floor"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.IMU Field

FileExtensionsIMU Field

Raw IMU data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string IMU = ".imu"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.JPG Field

FileExtensionsJPG Field

JPEG

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string JPG = ".jpg"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.JSON Field

FileExtensionsJSON Field

JSON

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string JSON = ".json"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.LBZ Field

FileExtensionsLBZ Field

LBZ

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string LBZ = ".lbz"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.META Field

FileExtensionsMETA Field

META

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string META = ".meta"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.PNG Field

FileExtensionsPNG Field

PNG

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string PNG = ".png"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileExtensions.Timestamps Field

FileExtensionsTimestamps Field

Timestamp data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string Timestamps = ".timestamps"

Field Value

Type: String
See Also

Reference

FileExtensions Class
LightBuzz.Kinect4Azure.Video Namespace


FileNames Class

The common video file name.s
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.VideoFileNames

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static class FileNames

The FileNames type exposes the following members.

Fields
Name | Description
Configuration | The configuration file.
Timestamps | The timestamps file.
Top
See Also

Reference

LightBuzz.Kinect4Azure.Video Namespace


FileNames Fields

The FileNames type exposes the following members.

Fields
Name | Description
Configuration | The configuration file.
Timestamps | The timestamps file.
Top
See Also

Reference

FileNames Class
LightBuzz.Kinect4Azure.Video Namespace


FileNames.Configuration Field

FileNamesConfiguration Field

The configuration file.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string Configuration = "configuration"

Field Value

Type: String
See Also

Reference

FileNames Class
LightBuzz.Kinect4Azure.Video Namespace


FileNames.Timestamps Field

FileNamesTimestamps Field

The timestamps file.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public const string Timestamps = "timestamps"

Field Value

Type: String
See Also

Reference

FileNames Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration Class

Video configuration settings.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.VideoVideoConfiguration

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class VideoConfiguration

The VideoConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | VideoConfiguration | Initializes a new instance of the VideoConfiguration class
Top
Properties
 | Name | Description
Public property | ColorResolution | The resolution of the color camera.
Public property | DepthResolution | The resolution of the depth camera.
Public property | Path | The path to the directory where the data will be saved.
Public property | RecordBody | Specifies whether the video should record body data.
Public property | RecordColor | Specifies whether the video should record color data.
Public property | RecordDepth | Specifies whether the video should record depth data.
Public property | RecordFloor | Specifies whether the video should record floor data.
Public property | RecordIMU | Specifies whether the video should record IMU data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration Constructor

Initializes a new instance of the VideoConfiguration class

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public VideoConfiguration()
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration Properties

The VideoConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ColorResolution | The resolution of the color camera.
Public property | DepthResolution | The resolution of the depth camera.
Public property | Path | The path to the directory where the data will be saved.
Public property | RecordBody | Specifies whether the video should record body data.
Public property | RecordColor | Specifies whether the video should record color data.
Public property | RecordDepth | Specifies whether the video should record depth data.
Public property | RecordFloor | Specifies whether the video should record floor data.
Public property | RecordIMU | Specifies whether the video should record IMU data.
Top
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration.ColorResolution Property

VideoConfigurationColorResolution Property

The resolution of the color camera.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Size ColorResolution { get; set; }

Property Value

Type: Size
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration.DepthResolution Property

VideoConfigurationDepthResolution Property

The resolution of the depth camera.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Size DepthResolution { get; set; }

Property Value

Type: Size
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration.Path Property

VideoConfigurationPath Property

The path to the directory where the data will be saved.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Path { get; set; }

Property Value

Type: String
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration.RecordBody Property

VideoConfigurationRecordBody Property

Specifies whether the video should record body data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool RecordBody { get; set; }

Property Value

Type: Boolean
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration.RecordColor Property

VideoConfigurationRecordColor Property

Specifies whether the video should record color data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool RecordColor { get; set; }

Property Value

Type: Boolean
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration.RecordDepth Property

VideoConfigurationRecordDepth Property

Specifies whether the video should record depth data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool RecordDepth { get; set; }

Property Value

Type: Boolean
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration.RecordFloor Property

VideoConfigurationRecordFloor Property

Specifies whether the video should record floor data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool RecordFloor { get; set; }

Property Value

Type: Boolean
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration.RecordIMU Property

VideoConfigurationRecordIMU Property

Specifies whether the video should record IMU data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool RecordIMU { get; set; }

Property Value

Type: Boolean
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoConfiguration Methods

The VideoConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VideoConfiguration Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper Class

Video utility methods for importing and exporting data.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.VideoVideoHelper

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static class VideoHelper

The VideoHelper type exposes the following members.

Methods
Name | Description
Export(IEnumerableDateTime) | Exports the specified list of timestamps.
Export(UInt16) | Exports the current raw depth data array in byte array format.
Export(Body) | Exports the current body to a string.
Export(IListBody) | Exports the current list of bodies to string.
Export(ColorFrameSource) | Exports the current raw color data array in byte array format.
Export(FloorFrameSource) | Exports the current floor data to string.
Export(IMUFrameSource) | Exports the current IMU data to string.
Export(VideoConfiguration) | Exports the current video configuration settings.
ImportBodyData | Imports a list of bodies from the specified string data.
ImportColorData | Imports the recorded color frame data.
ImportConfiguration | Imports the video configuration settings.
ImportDepthData | Imports the recorded depth data.
ImportFloorData | Imports the recorded floor data.
ImportIMUData | Imports the recorded IMU data.
ImportTimestamps | Imports the timestamps of the recorded frames.
Top
See Also

Reference

LightBuzz.Kinect4Azure.Video Namespace


VideoHelper Methods

The VideoHelper type exposes the following members.

Methods
Name | Description
Export(IEnumerableDateTime) | Exports the specified list of timestamps.
Export(UInt16) | Exports the current raw depth data array in byte array format.
Export(Body) | Exports the current body to a string.
Export(IListBody) | Exports the current list of bodies to string.
Export(ColorFrameSource) | Exports the current raw color data array in byte array format.
Export(FloorFrameSource) | Exports the current floor data to string.
Export(IMUFrameSource) | Exports the current IMU data to string.
Export(VideoConfiguration) | Exports the current video configuration settings.
ImportBodyData | Imports a list of bodies from the specified string data.
ImportColorData | Imports the recorded color frame data.
ImportConfiguration | Imports the video configuration settings.
ImportDepthData | Imports the recorded depth data.
ImportFloorData | Imports the recorded floor data.
ImportIMUData | Imports the recorded IMU data.
ImportTimestamps | Imports the timestamps of the recorded frames.
Top
See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method

VideoHelperExport Method

Overload List
Name | Description
Export(IEnumerableDateTime) | Exports the specified list of timestamps.
Export(UInt16) | Exports the current raw depth data array in byte array format.
Export(Body) | Exports the current body to a string.
Export(IListBody) | Exports the current list of bodies to string.
Export(ColorFrameSource) | Exports the current raw color data array in byte array format.
Export(FloorFrameSource) | Exports the current floor data to string.
Export(IMUFrameSource) | Exports the current IMU data to string.
Export(VideoConfiguration) | Exports the current video configuration settings.
Top
See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method (IEnumerable(DateTime))

VideoHelperExport Method (IEnumerableDateTime)

Exports the specified list of timestamps.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static string Export(
    IEnumerable<DateTime> timestamps
)

Parameters

timestamps
Type: System.Collections.GenericIEnumerableDateTime
The list of timestamps to export.

Return Value

Type: String
A string representation of the timestamp data.
See Also

Reference

VideoHelper Class
Export Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method (UInt16[])

VideoHelperExport Method (UInt16)

Exports the current raw depth data array in byte array format.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static byte[] Export(
    ushort[] data
)

Parameters

data
Type: SystemUInt16
The raw depth data to export.

Return Value

Type: Byte
A byte array representation of the ushort array data.
See Also

Reference

VideoHelper Class
Export Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method (Body)

VideoHelperExport Method (Body)

Exports the current body to a string.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static string Export(
    Body body
)

Parameters

body
Type: LightBuzz.Kinect4AzureBody
The body to export.

Return Value

Type: String
A string representation of the current body.
See Also

Reference

VideoHelper Class
Export Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method (IList(Body))

VideoHelperExport Method (IListBody)

Exports the current list of bodies to string.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static string Export(
    IList<Body> bodies
)

Parameters

bodies
Type: System.Collections.GenericIListBody
The bodies to export.

Return Value

Type: String
A string representation of the current bodies.
See Also

Reference

VideoHelper Class
Export Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method (ColorFrameSource)

VideoHelperExport Method (ColorFrameSource)

Exports the current raw color data array in byte array format.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static byte[] Export(
    ColorFrameSource source
)

Parameters

source
Type: LightBuzz.Kinect4AzureColorFrameSource
The color frame source to export.

Return Value

Type: Byte
A byte array representation of the raw array data.
See Also

Reference

VideoHelper Class
Export Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method (FloorFrameSource)

VideoHelperExport Method (FloorFrameSource)

Exports the current floor data to string.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static string Export(
    FloorFrameSource source
)

Parameters

source
Type: LightBuzz.Kinect4AzureFloorFrameSource
The floor frame source to export.

Return Value

Type: String
A string representation of the floor data.
See Also

Reference

VideoHelper Class
Export Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method (IMUFrameSource)

VideoHelperExport Method (IMUFrameSource)

Exports the current IMU data to string.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static string Export(
    IMUFrameSource source
)

Parameters

source
Type: LightBuzz.Kinect4AzureIMUFrameSource
The IMU frame source to export.

Return Value

Type: String
A string representation of the IMU data.
See Also

Reference

VideoHelper Class
Export Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.Export Method (VideoConfiguration)

VideoHelperExport Method (VideoConfiguration)

Exports the current video configuration settings.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static string Export(
    VideoConfiguration configuration
)

Parameters

configuration
Type: LightBuzz.Kinect4Azure.VideoVideoConfiguration
The video configuration settings.

Return Value

Type: String
A string representation of the video configuration.
See Also

Reference

VideoHelper Class
Export Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.ImportBodyData Method

VideoHelperImportBodyData Method

Imports a list of bodies from the specified string data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static IList<Body> ImportBodyData(
    string data
)

Parameters

data
Type: SystemString
The string data, exported using the VideoHelper.Export method.

Return Value

Type: IListBody

[Missing <returns> documentation for "M:LightBuzz.Kinect4Azure.Video.VideoHelper.ImportBodyData(System.String)"]

See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.ImportColorData Method

VideoHelperImportColorData Method

Imports the recorded color frame data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static ColorFrameSource ImportColorData(
    byte[] jpegData,
    int width,
    int height
)

Parameters

jpegData
Type: SystemByte
The JPEG data.
width
Type: SystemInt32
The width of the color frame.
height
Type: SystemInt32
The height of the color frame.

Return Value

Type: ColorFrameSource
The color frame data.
See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.ImportConfiguration Method

VideoHelperImportConfiguration Method

Imports the video configuration settings.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static VideoConfiguration ImportConfiguration(
    string data
)

Parameters

data
Type: SystemString
A string representation of the configuration data.

Return Value

Type: VideoConfiguration
The video configuration settings.
See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.ImportDepthData Method

VideoHelperImportDepthData Method

Imports the recorded depth data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static ushort[] ImportDepthData(
    byte[] data
)

Parameters

data
Type: SystemByte
The raw depth frame data.

Return Value

Type: UInt16
The depth frame data.
See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.ImportFloorData Method

VideoHelperImportFloorData Method

Imports the recorded floor data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static FloorFrameSource ImportFloorData(
    string data
)

Parameters

data
Type: SystemString
The raw floor frame data.

Return Value

Type: FloorFrameSource
The floor frame data.
See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.ImportIMUData Method

VideoHelperImportIMUData Method

Imports the recorded IMU data.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static IMUFrameSource ImportIMUData(
    string data
)

Parameters

data
Type: SystemString
The raw IMU frame data.

Return Value

Type: IMUFrameSource
The IMU frame data.
See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoHelper.ImportTimestamps Method

VideoHelperImportTimestamps Method

Imports the timestamps of the recorded frames.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static IList<DateTime> ImportTimestamps(
    string data
)

Parameters

data
Type: SystemString
A line-separated string of the timestamps.

Return Value

Type: IListDateTime
A list of timestamps of the recorded frames.
See Also

Reference

VideoHelper Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer Class

Loads recorded frames (Color, Depth, and Body data).
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.VideoVideoPlayer

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class VideoPlayer

The VideoPlayer type exposes the following members.

Constructors
 | Name | Description
Public method | VideoPlayer | Creates a new video recorder.
Public method | VideoPlayer(String) | Creates a new video recorder with the specified video path.
Top
Properties
 | Name | Description
Public property | Duration | The duration of the video.
Public property | Folder | The video recording folder.
Public property | FrameCount | The total number of video frames.
Public property | FrameRate | The number of frames per second of the current video.
Public property | IsPaused | Pauses or continues video playback.
Public property | IsPlaying | Checks whether the video player is playing.
Public property | Loop | Loop video playback.
Public property | Seek | Normalizes the current frame index to a value between 0.0 and 1.0.
Public property | Speed | The speed of the current video playback (e.g. 0.5, 1.0, 2.0, etc).
Public property | TimeElapsed | The elapsed time of the current frame.
Public property | Timestamps | A shorted list of the timestamps of each frame.
Top
Methods
 | Name | Description
Public method | Dispose | Releases resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts playing the video.
Public method | Stop | Stops playing the video.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Returns the frame to play.
Top
See Also

Reference

LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer Constructor

Overload List
 | Name | Description
Public method | VideoPlayer | Creates a new video recorder.
Public method | VideoPlayer(String) | Creates a new video recorder with the specified video path.
Top
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer Constructor

Creates a new video recorder.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public VideoPlayer()
See Also

Reference

VideoPlayer Class
VideoPlayer Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer Constructor (String)

Creates a new video recorder with the specified video path.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public VideoPlayer(
    string path
)

Parameters

path
Type: SystemString
The recording video path.
See Also

Reference

VideoPlayer Class
VideoPlayer Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer Properties

The VideoPlayer type exposes the following members.

Properties
 | Name | Description
Public property | Duration | The duration of the video.
Public property | Folder | The video recording folder.
Public property | FrameCount | The total number of video frames.
Public property | FrameRate | The number of frames per second of the current video.
Public property | IsPaused | Pauses or continues video playback.
Public property | IsPlaying | Checks whether the video player is playing.
Public property | Loop | Loop video playback.
Public property | Seek | Normalizes the current frame index to a value between 0.0 and 1.0.
Public property | Speed | The speed of the current video playback (e.g. 0.5, 1.0, 2.0, etc).
Public property | TimeElapsed | The elapsed time of the current frame.
Public property | Timestamps | A shorted list of the timestamps of each frame.
Top
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Duration Property

VideoPlayerDuration Property

The duration of the video.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TimeSpan Duration { get; }

Property Value

Type: TimeSpan
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Folder Property

VideoPlayerFolder Property

The video recording folder.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Folder { get; set; }

Property Value

Type: String
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.FrameCount Property

VideoPlayerFrameCount Property

The total number of video frames.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int FrameCount { get; }

Property Value

Type: Int32
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.FrameRate Property

VideoPlayerFrameRate Property

The number of frames per second of the current video.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int FrameRate { get; }

Property Value

Type: Int32
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.IsPaused Property

VideoPlayerIsPaused Property

Pauses or continues video playback.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool IsPaused { get; set; }

Property Value

Type: Boolean
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.IsPlaying Property

VideoPlayerIsPlaying Property

Checks whether the video player is playing.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool IsPlaying { get; }

Property Value

Type: Boolean
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Loop Property

VideoPlayerLoop Property

Loop video playback.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Loop { get; set; }

Property Value

Type: Boolean
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Seek Property

VideoPlayerSeek Property

Normalizes the current frame index to a value between 0.0 and 1.0.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Seek { get; set; }

Property Value

Type: Single
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Speed Property

VideoPlayerSpeed Property

The speed of the current video playback (e.g. 0.5, 1.0, 2.0, etc).

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public float Speed { get; set; }

Property Value

Type: Single
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.TimeElapsed Property

VideoPlayerTimeElapsed Property

The elapsed time of the current frame.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TimeSpan TimeElapsed { get; }

Property Value

Type: TimeSpan
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Timestamps Property

VideoPlayerTimestamps Property

A shorted list of the timestamps of each frame.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<DateTime> Timestamps { get; }

Property Value

Type: ListDateTime
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer Methods

The VideoPlayer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts playing the video.
Public method | Stop | Stops playing the video.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Returns the frame to play.
Top
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Dispose Method

VideoPlayerDispose Method

Releases resources.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Dispose()
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Start Method

VideoPlayerStart Method

Starts playing the video.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Start()
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Stop Method

VideoPlayerStop Method

Stops playing the video.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Stop()
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoPlayer.Update Method

VideoPlayerUpdate Method

Returns the frame to play.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Frame Update()

Return Value

Type: Frame
The frame to play.
See Also

Reference

VideoPlayer Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder Class

Records Color, Depth, and Body data.
Inheritance Hierarchy
SystemObject
LightBuzz.Kinect4Azure.VideoVideoRecorder

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class VideoRecorder

The VideoRecorder type exposes the following members.

Constructors
 | Name | Description
Public method | VideoRecorder | Creates a new video recorder with the default configuration settings.
Public method | VideoRecorder(VideoConfiguration) | Creates a new video recorder with the specified configuration settings.
Top
Properties
 | Name | Description
Public property | Configuration | The video recording configuration settings.
Public property | IsRecording | Specifies whether the recorder is currently recording frames.
Public property | IsSaving | Specifies whether the recorder is currently saving frames.
Public property | Timestamps | A list of the recorded timestamps in descending order.
Top
Methods
 | Name | Description
Public method | Dispose | Releases any resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts recording.
Public method | Stop | Stops recording.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Records the specified frame.
Top
Events
 | Name | Description
Public event | OnRecordingCompleted | Raised when the recording process has finished saving frames.
Public event | OnRecordingStarted | Raised when the recording process has started.
Public event | OnRecordingStopped | Raised when the recording process has stopped.
Top
See Also

Reference

LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder Constructor

Overload List
 | Name | Description
Public method | VideoRecorder | Creates a new video recorder with the default configuration settings.
Public method | VideoRecorder(VideoConfiguration) | Creates a new video recorder with the specified configuration settings.
Top
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder Constructor

Creates a new video recorder with the default configuration settings.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public VideoRecorder()
See Also

Reference

VideoRecorder Class
VideoRecorder Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder Constructor (VideoConfiguration)

Creates a new video recorder with the specified configuration settings.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public VideoRecorder(
    VideoConfiguration configuration
)

Parameters

configuration
Type: LightBuzz.Kinect4Azure.VideoVideoConfiguration
The recording configuration settings.
See Also

Reference

VideoRecorder Class
VideoRecorder Overload
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder Properties

The VideoRecorder type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | The video recording configuration settings.
Public property | IsRecording | Specifies whether the recorder is currently recording frames.
Public property | IsSaving | Specifies whether the recorder is currently saving frames.
Public property | Timestamps | A list of the recorded timestamps in descending order.
Top
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.Configuration Property

VideoRecorderConfiguration Property

The video recording configuration settings.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public VideoConfiguration Configuration { get; set; }

Property Value

Type: VideoConfiguration
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.IsRecording Property

VideoRecorderIsRecording Property

Specifies whether the recorder is currently recording frames.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool IsRecording { get; protected set; }

Property Value

Type: Boolean
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.IsSaving Property

VideoRecorderIsSaving Property

Specifies whether the recorder is currently saving frames.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool IsSaving { get; protected set; }

Property Value

Type: Boolean
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.Timestamps Property

VideoRecorderTimestamps Property

A list of the recorded timestamps in descending order.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public HashSet<DateTime> Timestamps { get; protected set; }

Property Value

Type: HashSetDateTime
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder Methods

The VideoRecorder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases any resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts recording.
Public method | Stop | Stops recording.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Records the specified frame.
Top
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.Dispose Method

VideoRecorderDispose Method

Releases any resources.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Dispose()
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.Start Method

VideoRecorderStart Method

Starts recording.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Start()
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.Stop Method

VideoRecorderStop Method

Stops recording.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Stop()
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.Update Method

VideoRecorderUpdate Method

Records the specified frame.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Update(
    Frame frame
)

Parameters

frame
Type: LightBuzz.Kinect4AzureFrame
The frame to record.
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder Events

The VideoRecorder type exposes the following members.

Events
 | Name | Description
Public event | OnRecordingCompleted | Raised when the recording process has finished saving frames.
Public event | OnRecordingStarted | Raised when the recording process has started.
Public event | OnRecordingStopped | Raised when the recording process has stopped.
Top
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.OnRecordingCompleted Event

VideoRecorderOnRecordingCompleted Event

Raised when the recording process has finished saving frames.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public event Action OnRecordingCompleted

Value

Type: SystemAction
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.OnRecordingStarted Event

VideoRecorderOnRecordingStarted Event

Raised when the recording process has started.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public event Action OnRecordingStarted

Value

Type: SystemAction
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace


VideoRecorder.OnRecordingStopped Event

VideoRecorderOnRecordingStopped Event

Raised when the recording process has stopped.

Namespace: LightBuzz.Kinect4Azure.Video
Assembly: LightBuzz.Kinect4Azure (in LightBuzz.Kinect4Azure.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public event Action OnRecordingStopped

Value

Type: SystemAction
See Also

Reference

VideoRecorder Class
LightBuzz.Kinect4Azure.Video Namespace